Hisnul-Muslim - Fatwa-Online©

Hisnul-Muslim - Fortification of the Muslim through remembrance and supplication from the Qur.aan and Sunnah

Fortification of the Muslim

through Remembrance and Supplication from the Qur.aan and Sunnah

Compiled and referenced by: Sa'eed Ibn Wahf Al-Qahtaanee

Adapted from a translation by: Ismael Ibraheem

Adapted by: Abu Safwan Farid Abdulwahid Haibatan

Revised by: Ismail Mahmoud Allakhami, The Translator of the Presidency of Islamic Researches, IFTA & Senior Scholars Commission, Riyadh.

..........

The Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) related that Allaah ordered Yahyaa Ibn Zakariyyah ('alayhis-salaam) with five commandments; to act upon them and convey them to the children of Israa.eel...[the fifth one being]: “...and I order you to make mention of Allaah often, as this is like a man being pursued at speed by the enemy until he reaches a protected fortress and so protects himself inside it, likewise is the servant, he can only protect himself from Shaytaan through remembrance of Allaah, the Mighty and Majestic.” [Saheeh al-Jaami', No.#1724]

This translation and publication of the original Arabic booklet was undertaken by Invitation to Islaam

http://www.invitationtoislam.com


Preface

al-Hamdu-Lillaahi Rabbil-'Aalameen was-Salaatu was-Salaamu 'alaa Ashrafil-Anbiyaa.e wal-Mursaleen, wa ba'd:

as-Salaam 'alaykum wa-Rahmatullaahe wa-Barakaatuhu,

Fatwa-Online is pleased to present the digital version(i) of the popular book of authentic supplications, "Hisnul-Muslim" compiled by the Shaykh, Sa'eed Ibn Wahf Al-Qahtaanee, and adapted into the English Language by Abu Safwan Farid Abdulwahid Haibatan.

We have made every effort to facilitate the maximum use of this ebook, hence, no protection has been used to safeguard against the copying and pasting of all the supplications throughout. In fact, we encourage you print each page, or even copy and paste the image of the supplication required to any desired program and then you can manipulate it as required to print and then affix to the wall or any other suitable place to aid memorisation, inshaa.-Allaah.

With regard to the references for the supplications listed, please refer to the printed version of the book as printed by Dar Al-Khair in Jeddah.

Much time and effort has gone into preparing this publication for FREE distribution and hence it is anticipated it will prove to be of immense value to the Muslims, inshaa.-Allaah. Therefore, whoever finds any typographical mistake(s) in the following work, then please write to me (at my email address) indicating the mistake(s) and its place.

{Our Lord! Punish us not if we forget or fall into error...}, [Soorah al-Baqarah, Aayah 286]

I thank all those who will point out these mistakes with the intention of seeking Allaah's Pleasure, and of correcting this publication. Indeed, Allaah is Surety over what I say.

May Allaah humble us all to make this effort pure, seeking His Face alone. Certainly to Him is our return.

{Our Lord accept from us, certainly you are the All-Hearing and All-Knowing}, [Soorah al-Baqarah, Aayah 127]

{Our Lord forgive me and my parents, and the believers on the Day when the reckoning will be established}, [Soorah Ibraaheem, Aayah 41]

«With the assistance of Allaah the Most High, and all Praise be to Allaah by whose favour good works are accomplished», [Ibn as-Sunnee in A'maal al-Yawm wal-Laylah; al-Haakim declared it Saheeh 1/499; al-Albaanee declared it Saheeh in Saheeh al-Jaami' 4/201]

wa Billaahit-Towfeeq...

Abu 'Abdullaah Mohammed Akhtar Chaudhry

abuabdullaah@fatwa-online.com

Graduate of the Faculty of Sharee'ah

Islaamic University of Madeenah

Visit us at: http://www.fatwa-online.com

Mirror site: http://www.efatwa.com

Email us at: mail@fatwa-online.com

Visit our other sites:

Thinking about making Hijra?

http://www.hijra.net

Thinking about getting married?

http://www.smatch.net

Some of the Students from the Islaamic University of Madeenah present:

http://www.madeenah.com

http://www.invitationtoislam.com

"hisnulmuslim.chm" was first published on al-Ithnayn 8 Shawwaal 1427 / Monday 30 October 2006

..........

(i) HTML HELP (file extension .CHM) is the default online help format for Windows 98, Windows ME, Windows 2000 and Windows XP. Older Windows versions (Windows 95 and Windows NT) require the Microsoft HTMP HELP viewer. In most cases, this viewer is already installed, because recent Microsoft products (MS Office) include it.


Notes

An audio cassette recording of the supplications in English and Arabic will be available in the near future, Allaah willing.

May Allaah reward those who have helped in this endeavour, amongst them: Dr. V. 'Abdur-Raheem, Dr. 'Adil 'Abdul-Ghaffaar, Muhammad Saleem Rajput, 'Abdur-Ra.oof Shakir, Burhan Loqueman, Farhat Abbas, Suleiman Pikin, Bashir Ali Umar, Mohammad Akhtar Chaudhry, Wajid Malik, Amar Bashir and Majid Sulayman al-Ghamlas.

A work of this kind will most definitely fall short of it’s intended aim, so we ask all those who can benefit us and in turn, the Ummah, with corrections or comments...etc, to contact us at the following address:

Dar Al-Khair

Ref: Hisn Al-Muslim

P.O. Box 32274

Jeddah 21428

K.S.A.

Scholars have varied opinions on the understanding of some of the supplications. In some of these cases we have cited an opinion which we consider is the most accurate, in other cases, when the opinions are in our view, of equal strength, we have cited one opinion only.

The word [image] is pronounced with an elongation after the [ [image] ]

i.e.

Blessed and exalted is Allaah

May Allaah send prayers and peace upon him

May Allaah be pleased with him

May Allaah have mercy upon him

Translated: “How perfect Allaah is” - complete meaning: “I exalt Allaah and elevate Him above having any defects or deficiencies.”


Translator’s note

Firstly, thanks and acknowledgment ought to be bestowed upon Brother Riyadhuddin for his diligent work in translating the piece before us. By the will of Allaah, the draft of his work was lost, which is when the present translator undertook this noble assignment.

Secondly, it should be stated clearly and emphatically from the onset that this translation in no way encourages the English speaking Muslim to take to supplicating and remembering his Lord in the English tongue as regards the following supplications, since the subject matter here stems from the Qur.aan and the Sunnah. Care should be taken to adhere to the language in which it was revealed, i.e. the eloquent tongue of the Arabs. Instead, what we desire is to present the English reader with an approximation of the meaning of the original, in the hope that through doing so, he may come to an improved state towards worshipping his Lord.

Our Lord, If we have been able in these pages to convey the true sense of the words of Your Prophet (sal-Allaahu 'alayhe wa sallam) then be patron over us and all those who benefit from this, and wherever we have failed in this effort, forgive us and protect the people from our errors.


Introduction

All praise is for Allaah. We praise Him and seek His help and forgiveness. We seek refuge in Allaah from the evil of ourselves and the wickedness of our own deeds. Whomever Allaah guides, cannot be lead astray and whomever Allaah misguides, none can guide him. I bear witness that none has the right to be worshipped except Allaah, alone without associate, and I bear witness that Muhammad is His slave and Messenger. Allaah praise him and send peace upon him, his household, and his companions and all those who follow them in righteousness till the Day of Reckoning.

The following pages are a selection from my book entitled:

and therefore the section compiled on remembrance and supplication has been abridged and compiled into this convenient pocket-size form. Indeed the text has also been summarized and accordingly I have limited myself to citing but a few of the sources contained in the original work. Thus, all those wishing further information regarding a particular companion or a particular narration, should refer to the original.

I ask Allaah Most Glorified, invoking His most beautiful names and His most sublime attributes, that He grant this endeavour sincerity, and make it beneficial for me in this life as well as the next. Furthermore, may all who read it find benefit, as well as those who print it or in some way serve to publicise it. Indeed Allaah is able to actualise that and is patron to such. O Allaah, send prayers upon the Prophet Muhammad, his household, and his companions and all those who follow them in righteousness till the Day of Reckoning.


The Excellence of Remembrance

Allaah (Subhaanahu wa Ta'aala) says:

{Therefore remember Me, I will remember you and be grateful to Me, and never be ungrateful to me}, [Soorah al-Baqarah, Aayah 152]

{O you who believe! Remember Allaah with much remembrance}, [Soorah al-Ahzaab, Aayah 41]

{And for men and women who engage much in Allaah's remembrance, for them has Allaah prepared forgiveness and great reward}, [Soorah al-Ahzaab, Aayah 35]

{And bring your Lord to remembrance in your [very] soul, with humility and remember without loudness in words, in the mornings and evenings; and be not of those who are unheedful}, [Soorah al-A'raaf, Aayah 205]

The Prophet (sal-Allaahu `alayhe wa sallam) said:

«The comparison of the one who remembers Allaah and the one who does not remember Allaah, is like that of the living and the dead», [al-Bukhaaree with al-Fat.h 11/208 and Muslim 1/539]

He (sal-Allaahu `alayhe wa sallam) also said:

«Should I not inform you of the best of deeds, and the most sanctifying of deeds before your Lord, which does more to raise your positions [with Him], and are better for you than the disbursement of gold and money or battle with the enemy?»

They [the companions] said: "Indeed! Inform us."

He (sal-Allaahu `alayhe wa sallam) then said:

«Remembrance of Allaah (Subhaanahu wa Ta'aala)», [at-Tirmidhee 5/459 and Ibn Maajah 2/1245, see: Saheeh Ibn Maajah 2/316 and Saheeh at-Tirmidhee 3/139]

The Prophet (sal-Allaahu `alayhe wa sallam) also said:

«Allaah (Subhaanahu wa Ta'aala) says: "Indeed I am as My servant presumes Me to be, and I am with him when he remembers Me, so if he remembers Me to himself I remember him to Myself, and if he remembers Me amongst a company I remember him amongst a company greater than it, and if he draws near to Me the span of a hand I draw near to him the span of an arm, and if he draws near to Me the span of an arm I draw near to him the span of two outstretched arms, and if he takes a step towards Me I hastily step towards him"», [al-Bukhaaree 8/171 and Muslim 4/2061, this specific wording is related by al-Bukhaaree]

On the authority of 'Abdullaah Ibn Busr (radhi-yallaahu 'anhu): "A man said to the Prophet (sal-Allaahu `alayhe wa sallam): "O Messenger of Allaah, the rites of Islaam are much for me, so tell me of something that I might hold fast to"

He (sal-Allaahu `alayhe wa sallam) said:

«Let not your tongue cease from the remembrance of Allaah», [at-Tirmidhee 5/458 and Ibn Maajah 2/1246, see: Saheeh at-Tirmidhee 3/139 and Saheeh Ibn Maajah 2/317]

The Prophet (sal-Allaahu `alayhe wa sallam) also said:

«Whoever recites a letter of Allaah's Book has for it, a merit and ten more like it, not to say that alif, laam, meem are one letter but rather alif is a letter, laam is a letter and meem is a letter», [at-Tirmidhee 5/175, see: Saheeh at-Tirmidhee 3/9 and Saheeh al-Jaami' as-Sagheer 5/340]

'Uqbah Ibn 'Aamir (radhi-yallaahu 'anhu) relates that Allaah's Messenger (sal-Allaahu `alayhe wa sallam) came out when we were in as-Suffah and said:

«Are there any of you who would wish to go every day to Buthaan or al-'Aeeq [i.e., the name of two ditches in al-Madeenah] in the early morning and return from it with two she-camels without incurring any sin or severing relations?»

We [the companions] said: "We would indeed love that, O Messenger of Allaah"

He (sal-Allaahu `alayhe wa sallam) said:

«Then you should go to the mosque and acquire some knowledge, or recite two aayaat from the Book of Allaah, that would be better for you than two she-camels, and three aayaat are better than three she-camels, and four aayaat are better than four she-camels, and the same for a like number of male camels», [Muslim 1/553]

The Prophet (sal-Allaahu `alayhe wa sallam) also said:

«Whoever takes a seat and fails to remember Allaah, has incurred upon himself a loss from Allaah, and whoever lies down [relaxes] and fails to remember Allaah, has incurred upon himself a loss from Allaah», [Abu Daawood 4/264 and others, see: Saheeh al-Jaami' 5/342.]

He (sal-Allaahu `alayhe wa sallam) also said:

«Whenever a people sit in a gathering in which they fail to remember Allaah and send prayers upon the Prophet they incur a loss upon themselves and if Allaah willed He would punish them and if He willed He would forgive them», [at-Tirmidhee, see: Saheeh at-Tirmidhee 3/140. ]

Similarly, he (sal-Allaahu `alayhe wa sallam) said:

«Whenever a people rise from a gathering in which they failed to remember Allaah, they rise as if they had arisen from the corpse of an ass and incurring upon themselves grief», [Abu Daawood 4/264 and Ahmad 2/389, see: Saheeh al-Jaami' 5/176]


[001.1] When waking up

‘All praise is for Allaah who gave us life after having taken it from us and unto Him is the resurrection.’


[001.2] When waking up

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong sovereignty and praise and He is over all things wholly capable. How perfect Allaah is, and all praise is for Allaah, and none has the right to be worshipped except Allaah, Allaah is the greatest and there is no power nor might except with Allaah, The Most High, The Supreme, O my Lord forgive me’.


[001.3] When waking up

‘All praise is for Allaah who restored to me my health and returned my soul and has allowed me to remember Him.’


[001.4] When waking up

Soorah Aal-'Imraan, Aayah 190-200


[002] When wearing a garment

‘All Praise is for Allaah who has clothed me with this [garment] and provided it for me, with no power nor might from myself.’


[003] When wearing a new garment

‘O Allaah, for You is all praise, You have clothed me with it, I ask You for the good of it and the good for which it was made, and I seek refuge with You from the evil of it and the evil for which it was made.’


[004.1] Supplication said to someone wearing a new garment

‘May you wear it out and Allaah (Ta'aala) replace it [with another].’


[004.2] Supplication said to someone wearing a new garment

‘Wear anew, live commendably and die a shaheed.’


[005] Before undressing

‘In the name of Allaah.’


[006] Before entering the toilet

‘[In the name of Allaah]. O Allaah, I take refuge with you from all evil and evil-doers.’


[007] After leaving the toilet

‘I ask You [Allaah] for forgiveness.’


[008] When starting ablution

‘In the name of Allaah.’


[009.1] Upon completing the ablution

‘I bear witness that none has the right to be worshipped except Allaah, alone, without any partner, and I bear witness that Muhammad is His slave and Messenger.’


[009.2] Upon completing the ablution

‘O Allaah, make me of those who return to You often in repentance and make me of those who remain clean and pure.’


[009.3] Upon completing the ablution

‘How perfect You are O Allaah, and I praise You, I bear witness that none has the right to be worshipped except You. I seek Your forgiveness and turn in repentance to You.’


[010.1] When leaving the home

‘In the name of Allaah, I place my trust in Allaah, and there is no might nor power except with Allaah.’


[010.2] When leaving the home

‘O Allaah, I take refuge with You lest I should stray or be led astray; slip or be tripped; oppress or be oppressed, or behave foolishly or be treated foolishly.’


[011] Upon entering the home

‘In the name of Allaah we enter and in the name of Allaah we leave, and upon our Lord we place our trust.’

...and then one should greet his family with salaam.


[012] Going to the mosque

‘O Allaah, place within my heart light; and upon my tongue light; and within my ears light; and within my eyes light; and place above me light; and beneath me light; and on my right light; and on my left light; and in front of me light; and behind me light; and place light within my soul; and augment light for me; and greaten light for me; and grant me light and make me light. O Allaah, bestow upon me light; and place light in my tendons; and light in my flesh; and light in my blood; and in light in my hair and light in my skin.’ [O Allaah, place light for me in my grave and light in my bones]. [And increase me with light and increase me with light and increase me with light]. [And grant me light upon light.]’


[013] Upon entering the mosque

‘I take refuge with Allaah, The Supreme and with His Noble Face, and His eternal authority from the accursed devil. In the name of Allaah, and prayers and peace be upon the Messenger of Allaah. O Allaah, open the gates of Your mercy for me.’


[014] Upon leaving the mosque

‘In the name of Allaah, and prayers and peace be upon the Messenger of Allaah. O Allaah, I ask You from Your favour. O Allaah, guard me from the accursed devil.’


[015] Supplications related to the adhaan [the call to prayer]

‘One repeats just as the mu.adhdhin [i.e., one who calls to prayer] says, except when he says:

or

‘come to prayer’ or ‘come to success’ Instead, one should say:

‘There is no might nor power except with Allaah.’

Immediately following the declaration of faith called by the mu.adhdhin, one says:

‘And I too bear witness that none has the right to be worshipped except Allaah, alone, without any partner, and that Muhammad is His slave and Messenger. I am pleased with Allaah as a Lord, and Muhammad as a Messenger and Islaam as a religion.’

‘One should then send prayers on the Prophet (sal-Allaahu 'alayhe wa sallam) after answering the call of the mu.adhdhin’.

‘O Allaah, Owner of this perfect call and Owner of this prayer to be performed, bestow upon Muhammad al-waseelah and al-fadheelah and send him upon a praised platform which You have promised him. [Verily, You never fail in Your promise].’

One should also supplicate for himself during the time between the adhaan and the iqaamah, as supplication at such time is not rejected.


[016.1] Supplication at the start of the prayer [after takbeer]

‘O Allaah, distance me from my sins just as You have distanced The East from The West. O Allaah, purify me of my sins as a white robe is purified of filth. O Allaah, cleanse me of my sins with snow, water, and hail.’


[016.2] Supplication at the start of the prayer [after takbeer]

‘How perfect You are O Allaah, and I praise You. Blessed be Your name, and lofty is Your majesty and none has the right to be worshipped except You.’


[016.3] Supplication at the start of the prayer [after takbeer]

‘I have turned my face sincerely towards He who has brought forth the heavens and the earth and I am not of those who associate [others with Allaah]. Indeed my prayer, my sacrifice, my life and my death are for Allaah, Lord of the worlds, no partner has He, with this I am commanded and I am of the Muslims. O Allaah, You are the Sovereign, none has the right to be worshipped except You. You are my Lord and I am Your servant, I have wronged my own soul and have acknowledged my sin, so forgive me all my sins for no one forgives sins except You. Guide me to the best of characters for none can guide to it other than You, and deliver me from the worst of characters for none can deliver me from it other than You. Here I am, in answer to Your call, happy to serve you. All good is within Your hands and evil does not stem from You . I exist by your will and will return to you. Blessed and High are You, I seek Your forgiveness and repent unto You.’


[016.4] Supplication at the start of the prayer [after takbeer]

‘O Allaah, Lord of Jibreel, Meekaa.eel and Israafeel [great angels], Creator of the heavens and the earth, Knower of the seen and the unseen. You are the arbitrator between Your servants in that which they have disputed. Guide me to the truth by Your leave, in that which they have differed, for verily You guide whom You will to a straight path.’


[016.5] Supplication at the start of the prayer [after takbeer]

‘Allaah is Most Great, Allaah is Most Great, Allaah is Most Great, much praise is for Allaah, much praise is for Allaah, much praise is for Allaah, and I declare the perfection of Allaah in the early morning and in the late afternoon.’ [three times]

‘I take refuge with Allaah from the devil, from his pride, his poetry and his madness.’


[016.6] Supplication at the start of the prayer [after takbeer]

The Prophet (sal-Allaahu 'alayhe wa sallam) would say [as an opening supplication in prayer] when rising from sleep to perform prayers during the night:

‘O Allaah, to You belongs all praise, You are the Light of the heavens and the earth and all that is within them. To You belongs all praise, You are the Sustainer of the heavens and the earth and all that is within them. To You belongs all praise. You are Lord of the heavens and the earth and all that is within them. To You belongs all praise and the kingdom of the heavens and the earth and all that is within them. To You belongs all praise, You are the King of the heavens and the earth and to You belongs all praise. You are The Truth, Your promise is true, your Word is true, and the Day in which we will encounter You is true, the Garden of Paradise is true and the Fire is true, and the Prophets are true, Muhammad (sal-Allaahu 'alayhe wa sallam) is true and the Final Hour is true. O Allaah, unto You I have submitted, and upon You I have relied, and in You I have believed, and to You I have turned in repentance, and over You I have disputed, and to You I have turned for judgment. So forgive me for what has come to pass of my sins and what will come to pass, and what I have hidden and what I have made public. You are al-Muqaddim and al-Mu.akhkhir. None has the right to be worshipped except You, You are my Deity, none has the right to be worshipped except You.’


[017.1] While bowing in prayer [rukoo]

‘How perfect my Lord is, The Supreme.’ [three times]


[017.2] While bowing in prayer [rukoo]

‘How perfect You are O Allaah, our Lord, and I praise You. O Allaah, forgive me.’


[017.3] While bowing in prayer [rukoo]

‘Perfect and Holy [He is], Lord of the angels and the Rooh [i.e., Jibreel].’


[017.4] While bowing in prayer [rukoo]

‘O Allaah, unto You I have bowed, and in You I have believed, and to You I have submitted. My hearing, sight, mind, bones, tendons and what my feet carry are humbled before You.’


[017.5] While bowing in prayer [rukoo]

‘How perfect He is, The Possessor of total power, sovereignty, magnificence and grandeur.’


[018.1] Upon rising from the bowing position

‘May Allaah answer the one who praises Him.’


[018.2] Upon rising from the bowing position

‘Our Lord, for You is all praise, an abundant beautiful blessed praise.’


[018.3] Upon rising from the bowing position

‘The heavens and the earth and all between them abound with Your praises, and all that You will abounds with Your praises. O Possessor of praise and majesty, the truest thing a slave has said [of You] and we are all Your slaves. O Allaah, none can prevent what You have willed to bestow and none can bestow what You have willed to prevent, and no wealth or majesty can benefit anyone, as from You is all wealth and majesty.’


[019.1] Whilst prostrating [sujood]

‘How Perfect my Lord is, The Most High.’ [three times]


[019.2] Whilst prostrating [sujood]

‘How perfect You are O Allaah, our Lord, and I praise You. O Allaah, forgive me.’


[019.3] Whilst prostrating [sujood]

‘Perfect and Holy [He is], Lord of the angels and the Rooh [i.e., Jibreel].’


[019.4] Whilst prostrating [sujood]

‘O Allaah, unto You I have prostrated and in You I have believed, and unto You I have submitted. My face has prostrated before He Who created it and fashioned it, and brought forth its faculties of hearing and seeing. Blessed is Allaah, the Best of creators.’


[019.5] Whilst prostrating [sujood]

‘How perfect He is, The Possessor of total power, sovereignty, magnificence and grandeur.’


[019.6] Whilst prostrating [sujood]

‘O Allaah, forgive me all of my sins, the small and great of them, the first and last of them, and the seen and hidden of them.’


[019.7] Whilst prostrating [sujood]

‘O Allaah, I take refuge within Your pleasure from Your displeasure and within Your pardon from Your punishment, and I take refuge in You from You. I cannot enumerate Your praise. You are as You have praised Yourself.’


[020.1] Between the two prostrations

‘My Lord forgive me, My Lord forgive me.’


[020.2] Between the two prostrations

‘O Allaah, forgive me, have mercy upon me, guide me, enrich me, give me health, grant me sustenance and raise my rank.’


[021.1] When prostrating due to recitation of the Qur.aan

‘My face fell prostrate before He who created it and brought forth its faculties of hearing and seeing by His might and power.'

[Soorah al-Mu.minoon, Aayah 14]

“So Blessed is Allaah, the best of creators”.


[021.2] When prostrating due to recitation of the Qur.aan

‘O Allaah, record for me a reward for this [prostration], and remove from me a sin. Save it for me and accept it from me just as You had accepted it from Your servant Daawood.’


[022] The Tashahhud

‘at-Tahiyyaat is for Allaah. All acts of worship and good deeds are for Him. Peace and the mercy and blessings of Allaah be upon you O Prophet. Peace be upon us and all of Allaah’s righteous servants. I bear witness that none has the right to be worshipped except Allaah and I bear witness that Muhammad is His slave and Messenger.’


[023.1] Prayers upon the Prophet after the tashahhud

‘O Allaah, send prayers upon Muhammad and the followers of Muhammad, just as You sent prayers upon Ibraaheem and upon the followers of Ibraaheem. Verily, You are full of praise and majesty. O Allaah, send blessings upon Muhammad and upon the family of Muhammad, just as You sent blessings upon Ibraaheem and upon the family of Ibraaheem. Verily, You are full of praise and majesty.’


[023.2] Prayers upon the Prophet after the tashahhud

‘O Allaah, send prayers upon Muhammad and upon the wives and descendants of Muhammad, just as You sent prayers upon the family of Ibraaheem, and send blessings upon Muhammad and upon the wives and descendants of Muhammad, just as You sent blessings upon the family of Ibraaheem. Verily, You are full of praise and majesty.’


[024.1] Supplication said after the last tashahhud and before salaam

‘O Allaah, I take refuge in You from the punishment of the grave, from the torment of the Fire, from the trials and tribulations of life and death and from the evil affliction of al-Maseeh ad-Dajjaal.’


[024.2] Supplication said after the last tashahhud and before salaam

‘O Allaah, I take refuge in You from the punishment of the grave, and I take refuge in You from the temptation and trial of al-Maseeh ad-Dajjaal, and I take refuge in You from the trials and tribulations of life and death. O Allaah, I take refuge in You from sin and debt.’


[024.3] Supplication said after the last tashahhud and before salaam

‘O Allaah, I have indeed oppressed my soul excessively and none can forgive sin except You, so forgive me a forgiveness from Yourself and have mercy upon me. Surely, You are The Most-Forgiving, The Most-Merciful.’


[024.4] Supplication said after the last tashahhud and before salaam

‘O Allaah, forgive me for those sins which have come to pass as well as those which shall come to pass, and those I have committed in secret as well as those I have made public, and where I have exceeded all bounds as well as those things about which You are more knowledgeable. You are al-Muqaddim and al-Mu.akhkhir. None has the right to be worshipped except You.’


[024.5] Supplication said after the last tashahhud and before salaam

‘O Allaah, help me to remember You, to thank You, and to worship You in the best of manners.’


[024.6] Supplication said after the last tashahhud and before salaam

‘O Allaah, I take refuge in You from miserliness and cowardice, I take refuge in You lest I be returned to the worst of lives , and I take refuge in You from the trials and tribulations of this life and the punishment of the grave.’


[024.7] Supplication said after the last tashahhud and before salaam

‘O Allaah, I ask You to grant me Paradise and I take refuge in You from the Fire.’


[024.8] Supplication said after the last tashahhud and before salaam

‘O Allaah, by Your knowledge of the unseen and Your power over creation, keep me alive so long as You know such life to be good for me and take me if You know death to be better for me. O Allaah, make me fearful of You whether in secret or in public and I ask You to make me true in speech, in times of pleasure and anger. I ask you to make me moderate in times of wealth and poverty and I ask You for everlasting bliss and joy which will never cease. I ask You to make me pleased with what You have decreed and for an easy life after death. I ask You for the sweetness of looking upon Your Face and a longing to encounter You in a manner which does not entail a calamity which will bring about harm nor a trial which will cause deviation. O Allaah, beautify us with the adornment of faith and make us of those who guide and are rightly guided.’


[024.9] Supplication said after the last tashahhud and before salaam

‘O Allaah, I ask You O Allaah, as You are The One, The Only, as-Samad, The One who begets not, nor was He begotten and there is none like unto Him, that You forgive me my sins for verily You are The Oft-Forgiving, Most-Merciful.’


[024.10] Supplication said after the last tashahhud and before salaam

‘O Allaah, I ask You as unto You is all praise, none has the right to be worshipped except You, alone, without any partner. You are the Benefactor. O Originator of the heavens and the Earth, O Possessor of majesty and honour, O Ever Living, O Self-Subsisting and Supporter of all, verily I ask You for Paradise and I take refuge with You from the Fire.’


[024.11] Supplication said after the last tashahhud and before salaam

‘O Allaah, I ask You, as I bear witness that You are Allaah, none has the right to be worshipped except You, The One, as-Samad Who begets not nor was He begotten and there is none like unto Him.’


[025.1] Remembrance after salaam

‘I ask Allaah for forgiveness.’ [three times]

‘O Allaah, You are as-Salaam and from You is all peace, blessed are You, O Possessor of majesty and honour.’


[025.2] Remembrance after salaam

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise and He is over all things omnipotent. O Allaah, none can prevent what You have willed to bestow and none can bestow what You have willed to prevent, and no wealth or majesty can benefit anyone, as from You is all wealth and majesty.’


[025.3] Remembrance after salaam

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise and He is over all things omnipotent. There is no might nor power except with Allaah, none has the right to be worshipped except Allaah and we worship none except Him. For Him is all favour, grace, and glorious praise. None has the right to be worshipped except Allaah and we are sincere in faith and devotion to Him although the disbelievers detest it.’


[025.4] Remembrance after salaam

‘How perfect Allaah is, all praise is for Allaah, and Allaah is the greatest.’ [thirty-three times]

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise and He is over all things omnipotent.’


[025.5] Remembrance after salaam

The following three Soorahs should be recited once after Zuhr, 'Asr and 'Ishaa prayers and thrice after the Fajr and Maghrib prayers.

[Soorah al-Ikhlaas (112)]

[Soorah al-Falaq (113)]

[Soorah an-Naas (114)]


[025.6] Remembrance after salaam

It is also from the Sunnah to recite Aayat ul-Kursee after each prayer:

[Soorah al-Baqarah, Aayah 255]


[025.7] Remembrance after salaam

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise, He gives life and causes death and He is over all things omnipotent.’ [ten times after the Maghrib and Fajr prayers]


[025.8] Remembrance after salaam

‘O Allaah, I ask You for knowledge which is beneficial and sustenance which is good, and deeds which are acceptable.’ [To be said after giving salaam for the Fajr prayer]


[026] Seeking guidance in forming a decision or choosing the proper course etc. [al Istikhaarah]

On the authority of Jaabir Ibn 'Adbullaah (radhi-yAllaahu 'anhu), he said: ‘The Prophet (sal-Allaahu 'alayhe wa sallam) would instruct us to pray for guidance in all of our concerns, just as he would teach us a Soorah from the Qur.aan. He (sal-Allaahu 'alayhe wa sallam) would say ‘If any of you intends to undertake a matter then let him pray two supererogatory units [two rak'ah naafilah] of prayer and after which he should supplicate:

‘O Allaah, I seek Your counsel by Your knowledge and by Your power I seek strength and I ask you from Your immense favour, for verily You are able while I am not and verily You know while I do not and You are the Knower of the unseen. O Allaah, if You know this affair -and here he mentions his need- to be good for me in relation to my religion, my life, and end, then decree and facilitate it for me, and bless me with it, and if You know this affair to be ill for me towards my religion, my life, and end, then remove it from me and remove me from it, and decree for me what is good wherever it be and make me satisfied with such.’

One who seeks guidance from his Creator and consults his fellow believers and then remains firm in his resolve does not regret, for Allaah has said:

‘...and consult them in the affair. Then when you have taken a decision put your trust in Allaah...’

[Soorah Aal 'Imraan, Aayah 159]


[027] Remembrance said in the morning and evening

‘All praise is for Allaah, alone, and prayers and peace be upon the last and final Prophet.’

‘I take refuge with Allaah from the accursed devil.’

Then recite Aayatul-Kursee:

Then recite Soorah al-Ikhlaas:

Then recite Soorah al-Falaq:

Then recite Soorah an-Naas:

...[three times]

‘We have reached the morning and at this very time unto Allaah, belongs all sovereignty , and all praise is for Allaah. None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise and He is over all things omnipotent. My Lord, I ask You for the good of this day and the good of what follows it and I take refuge in You from the evil of this day and the evil of what follows it . My Lord, I take refuge in You from laziness and senility. My Lord, I take refuge in You from torment in the Fire and punishment in the grave.’

‘O Allaah, by your leave we have reached the morning and by Your leave we have reached the evening, by Your leave we live and die and unto You is our resurrection.’

In the evening:

‘O Allaah, by Your leave we have reached the evening and by Your leave we have reached the morning, by Your leave we live and die and unto You is our return.’

‘O Allaah, You are my Lord, none has the right to be worshipped except You, You created me and I am Your servant and I abide to Your covenant and promise as best I can, I take refuge in You from the evil of which I have committed. I acknowledge Your favour upon me and I acknowledge my sin, so forgive me, for verily none can forgive sin except You.’

‘O Allaah, verily I have reached the morning and call on You, the bearers of Your throne, Your angels, and all of Your creation to witness that You are Allaah, none has the right to be worshipped except You, alone, without any partner and that Muhammad is Your Servant and Messenger.’ [four times in the morning and evening.]

‘O Allaah, what blessing I or any of Your creation have risen upon, is from You alone, without any partner, so for You is all praise and unto You all thanks.’

...whoever says this in the morning has indeed offered his day’s thanks and whoever says this in the evening has indeed offered his night’s thanks.

‘O Allaah, grant my body health, O Allaah, grant my hearing health, O Allaah, grant my sight health. None has the right to be worshipped except You. O Allaah, I take refuge with You from disbelief and poverty, and I take refuge with You from the punishment of the grave. None has the right to be worshipped except You.’ [three times]

‘Allaah is Sufficient for me, none has the right to be worshipped except Him, upon Him I rely and He is Lord of the exalted throne.’ [seven times morning and evening]

‘O Allaah, I ask You for pardon and well-being in this life and the next. O Allaah, I ask You for pardon and well-being in my religious and worldly affairs, and my family and my wealth. O Allaah, veil my weaknesses and set at ease my dismay. O Allaah, preserve me from the front and from behind and on my right and on my left and from above, and I take refuge with You lest I be swallowed up by the earth.’

‘O Allaah, Knower of the unseen and the seen, Creator of the heavens and the Earth, Lord and Sovereign of all things, I bear witness that none has the right to be worshipped except You. I take refuge in You from the evil of my soul and from the evil and shirk of the devil, and from committing wrong against my soul or bringing such upon another Muslim.’

‘In the name of Allaah with whose name nothing is harmed on earth nor in the heavens and He is The All-Seeing, The All-Knowing.’ [three times]

‘I am pleased with Allaah as a Lord, and Islaam as a religion and Muhammad as a Prophet.’ [three times]

‘O Ever Living, O Self-Subsisting and Supporter of all, by Your mercy I seek assistance, rectify for me all of my affairs and do not leave me to myself, even for the blink of an eye.’

‘We have reached the morning and at this very time all sovereignty belongs to Allaah, Lord of the worlds. O Allaah, I ask You for the good of this day, its triumphs and its victories, its light and its blessings and its guidance, and I take refuge in You from the evil of this day and the evil that follows it.’

‘We rise upon the fitrah of Islaam, and the word of pure faith , and upon the religion of our Prophet Muhammad and the religion of our forefather Ibraaheem, who was a Muslim and of true faith and was not of those who associate others with Allaah.’

‘How perfect Allaah is and I praise Him.’ [one hundred times]

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise, and He is over all things omnipotent.’ [ten times or once if lazy]

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belong all sovereignty and praise and He is over all things omnipotent.’ [one hundred times in the morning]

‘How perfect Allaah is and I praise Him by the number of His creation and His pleasure, and by the weight of His throne, and the ink of His words.’ [three times in the morning]

‘O Allaah, I ask You for knowledge which is beneficial and sustenance which is good, and deeds which are acceptable.’ [in the morning]

‘I seek Allaah’s forgiveness and I turn to Him in repentance.’ [one hundred times a day]

‘I take refuge in Allaah’s perfect words from the evil He has created.’ [three times in the evening]

‘O Allaah, send prayers and peace upon our Prophet Muhammad.’ [ten times]


[028] Remembrance before sleeping

‘When retiring to his bed every night, The Prophet (sal-Allaahu 'alayhe wa sallam) would hold his palms together, and (whilst blowing - would) lightly spit in them, recite the last three chapters of the Qur.aan and then wipe over his entire body as much as possible with his hands, beginning with his head and face and then all parts of the body, he would do this three times.’

The Prophet (sal-Allaahu 'alayhe wa sallam) also said: ‘When you are about to sleep recite Aayah-ul-Kursee till the end of the Aayah for there will remain over you a protection from Allaah and no devil will draw near to you until morning.’

The Prophet (sal-Allaahu 'alayhe wa sallam) also said: ‘Whoever recites the last two Aayahs of Soorah al-Baqarah at night, those two Aayahs shall be sufficient for him .’

[Soorah al-Baqarah, Aayahs 285-286]

‘If one of you rises from his bed and then returns to it he should dust it with the edge of his garment three times for he does not know what has occurred in his absence and when he lies down he should supplicate:

‘In Your name my Lord, I lie down and in Your name I rise, so if You should take my soul then have mercy upon it, and if You should return my soul then protect it in the manner You do so with Your righteous servants.’

‘O Allaah, verily You have created my soul and You shall take it’s life, to You belong it’s life and death. If You should keep my soul alive then protect it, and if You should take it’s life then forgive it. O Allaah, I ask You to grant me good health.’

The Prophet (sal-Allaahu 'alayhe wa sallam) would place his right hand under his cheek when about to sleep and supplicate:

‘O Allaah, protect me from Your punishment on the day Your servants are resurrected.’ [three times]

‘In Your name O Allaah, I live and die.’

‘Shall I not direct you both to something better than a servant? When you go to bed say:

‘How Perfect Allaah is.’ [thirty-three times]

‘All praise is for Allaah.’ [thirty-three times]

‘Allaah is the greatest.’ [thirty-four times]

...for that is indeed better for you both than a servant.’

‘O Allaah, Lord of the seven heavens and the exalted throne, our Lord and Lord of all things, Splitter of the seed and the date stone, Revealer of the Towraat, the Injeel and the Furqaan, I take refuge in You from the evil of all things You shall seize by the forelock . O Allaah, You are The First so there is nothing before You and You are The Last so there is nothing after You. You are ath-Thaahir so there is nothing above You and You are al-Baatin so there is nothing closer than You. Settle our debt for us and spare us from poverty.’

‘All praise is for Allaah, Who fed us and gave us drink, and Who is sufficient for us and has sheltered us, for how many have none to suffice them or shelter them.’

‘O Allaah, Knower of the seen and the unseen, Creator of the heavens and the earth, Lord and Sovereign of all things I bear witness that none has the right to be worshipped except You. I take refuge in You from the evil of my soul and from the evil and shirk of the devil, and from committing wrong against my soul or bringing such upon another Muslim.’

‘The Prophet (sal-Allaahu 'alayhe wa sallam) never used to sleep until he had recited Soorah as-Sajdah and Soorah al-Mulk .’

‘If you take to your bed, then perform ablution, lie on your right side and then supplicate:

‘O Allaah, I submit my soul unto You, and I entrust my affair unto You, and I turn my face towards You, and I totally rely on You, in hope and fear of You. Verily there is no refuge nor safe haven from You except with You. I believe in Your Book which You have revealed and in Your Prophet whom You have sent.’

...If you then die, you will die upon the fitrah .’


[029] Supplication when turning over during the night

'Aa.ishah (radhi-yAllaahu 'Anhaa) narrated that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) used to say at night if he turned during sleep:

‘None has the right to be worshipped except Allaah, The One, al-Qahhaar . Lord of the heavens and the Earth and all between them, The Exalted in Might, The Oft-Forgiving.’


[030] Upon experiencing unrest, fear, apprehensiveness and the like during sleep

‘I take refuge in the perfect words of Allaah from His anger and punishment, and from the evil of His servants, and from the madness and appearance of devils.’


[031] Upon seeing a good dream or a bad dream

‘The righteous dream is from Allaah and the bad dream is from the devil, so if anyone sees something which pleases him then he should only relate it to one whom he loves...’

Summary of what to do upon having a bad dream:

• spit on your left three times.

• Seek refuge in Allaah from Shaytaan and the evil of what you saw three times.

• Do not relate it to anyone.

• Turn and sleep on the opposite side to which you were sleeping on previously.

• Get up and pray if you so desire.


[032] Qunoot al-Witr

‘O Allaah, guide me along with those whom You have guided, pardon me along with those whom You have pardoned, be an ally to me along with those whom You are an ally to and bless for me that which You have bestowed. Protect me from the evil You have decreed for verily You decree and none can decree over You. For surety, he whom you show allegiance to is never abased and he whom You take as an enemy is never honoured and mighty. O our Lord, Blessed and Exalted are You.’

‘O Allaah, I take refuge within Your pleasure from Your displeasure and within Your pardon from Your punishment, and I take refuge in You from You. I cannot enumerate Your praise. You are as You have praised Yourself.’

‘O Allaah, it is You we worship, and unto You we pray and prostrate, and towards You we hasten and You we serve. We hope for Your mercy and fear Your punishment, verily Your punishment will fall upon the disbelievers. O Allaah, we seek Your aid and ask Your pardon, we praise You with all good and do not disbelieve in You. We believe in You and submit unto You, and we disown and reject those who disbelieve in You.’


[033] After salaam of the witr prayer

After giving salaam he would supplicate three times:

‘How perfect The King, The Holy One is.’

....on the third time he would raise his voice, elongate it and add:

‘Lord of the angels and the Rooh [i.e., Jibreel].’


[034] Anxiety and sorrow

‘O Allaah, I am Your servant, son of Your servant, son of Your maidservant, my forelock is in Your hand , Your command over me is forever executed and Your decree over me is just. I ask You by every name belonging to You which You named Yourself with, or revealed in Your Book, or You taught to any of Your creation, or You have preserved in the knowledge of the unseen with You, that You make the Qur.aan the life of my heart and the light of my breast, and a departure for my sorrow and a release for my anxiety.’

‘O Allaah, I take refuge in You from anxiety and sorrow, weakness and laziness, miserliness and cowardice, the burden of debts and from being over powered by men.’


[035] Supplication for one in distress

‘None has the right to be worshipped except Allaah, The Supreme, The Most-Forbearing. None has the right to be worshipped except Allaah, Lord of the magnificent throne. None has the right to be worshipped except Allaah, Lord of the heavens, Lord of the earth and Lord of the noble throne.’

‘O Allaah, it is Your mercy that I hope for, so do not leave me in charge of my affairs even for a blink of an eye and rectify for me all of my affairs. None has the right to be worshipped except You.’

‘None has the right to be worshipped except You. How perfect You are, verily I was among the wrong-doers.’

‘Allaah, Allaah is my Lord, I do not associate anything with Him.’


[036] Upon encountering an enemy or those of authority

‘O Allaah, we place You before them and we take refuge in You from their evil.’

‘O Allaah, You are my supporter and You are my helper, by You I move and by You I attack and by You I battle.’

‘Allaah is sufficient for us, and how fine a trustee [He is].’


[037] Supplication for one afflicted with doubt in his faith

• He should seek refuge in Allaah

• He should renounce that which is causing such doubt

• He should say:

‘I have believed in Allaah and His Messengers.’

• He should also recite the following Aayah:

‘He is The First and The Last, ath-Thaahir and al-Baatin and He knows well all things.’ [al-Hadeed, Aayah 3]


[038] Settling a debt

‘O Allaah, make what is lawful enough for me, as opposed to what is unlawful, and spare me by Your grace, of need of others.’

‘O Allaah, I take refuge in You from anxiety and sorrow, weakness and laziness, miserliness and cowardice, the burden of debts and from being over powered by men.’


[039] Supplication for one afflicted by whisperings in prayer or recitation

'Uthmaan Ibn al-'Aas (radhi-yAllaahu 'anhu) narrated: I said ‘O Messenger of Allaah, verily the devil comes between me and my prayer and recitation making me confused’ The Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) replied ‘That is a devil called Khanzab, so if you sense his presence then seek refuge in Allaah from him and spit on your left side three times.’


[040] Supplication for one whose affairs have become difficult

‘O Allaah, there is no ease except in that which You have made easy, and You make the difficulty, if You wish, easy.’


[041] Upon committing a sin

‘Any servant who commits a sin and as a result, performs ablution, prays two units of prayer [i.e., two rak1ats] and then seeks Allaah’s forgiveness, Allaah would forgive him.’


[042] Supplications for expelling the devil and his whisperings

• Seeking refuge from him.

• The Adhaan [call to prayer].

• Recitation of the Qur.aan and the [authentic] words of remembrance and supplications.


[043] When stricken with a mishap or overtaken by an affair

‘The strong believer is better and more beloved to Allaah, than the weak believer and there is goodness in both. Strive for that which will benefit you, seek help from Allaah and do not despair . If a mishap should happen to befall you then do not say ‘ If only I had acted...such and such would have happened’. Rather, say:

‘Allaah has decreed and what He wills, He does.’

...for verily ‘If ‘ lets in the work of the devil.’

Indeed Allaah (Subhaanahu wa Ta'aala) rebukes due to negligence and slackness, but take to determination and caution, and if a matter should overtake you then say:

‘Allaah is sufficient for me, and how fine a trustee (He is).’


[044] Placing children under Allaah’s protection

Ibn 'Abbaas (radhi-yAllaahu 'anhumaa) related that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) used to commend al-Hasan and al-Husayn to Allaah’s protection, saying:

‘I commend you two to the protection of Allaah’s perfect words from every devil, vermin, and every evil eye.’


[045] When visiting the sick

When The Prophet (sal-Allaahu 'alayhe wa sallam) would enter upon a sick person, he would say:

‘Never mind, may it [the sickness] be a purification, if Allaah wills.’

‘Any Muslim servant who visits a sick person whose prescribed moment of death has not arrived and supplicates seven times:

‘I ask Allaah The Supreme, Lord of the magnificent throne to cure you’.

...he [i.e., the sick person] will be cured.’ [seven times]


[046] Excellence of visiting the sick

'Alee ibn Abee Taalib (radhi-yAllaahu 'anhu) related that he heard the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) say: ‘If a man calls on his sick Muslim brother, it is as if he walks reaping the fruits of Paradise until he sits, and when he sits he is showered in mercy, and if this was in the morning, seventy thousand angels send prayers upon him until the evening, and if this was in the evening, seventy thousand angels send prayers upon him until the morning.’


[047] Supplication of the sick who have renounced all hope of life

‘O Allaah, forgive me, have mercy upon me and unite me with the highest companions .’

'Aa.ishah (radhi-yAllaahu 'anhaa) related that The Prophet (sal-Allaahu 'alayhe wa sallam) [during his illness in which he passed away] would dip his hands in water and then he would wipe his face and say:

‘None has the right to be worshipped except Allaah, death does indeed contain agony.’

‘None has the right to be worshipped except Allaah and Allaah is the greatest. None has the right to be worshipped except Allaah, alone. None has the right to be worshipped except Allaah, alone, without any partner. None has the right to be worshipped except Allaah, to Him belong all sovereignty and praise. None has the right to be worshipped except Allaah and there is no might and no power except with Allaah.’


[048] Instruction for the one nearing death

‘He whose last words are:

‘None has the right to be worshipped except Allaah.’

...will enter Paradise.’


[049] Supplication for one afflicted by a calamity

‘To Allaah we belong and unto Him is our return. O Allaah, recompense me for my affliction and replace it for me with something better.’


[050] When closing the eyes of the deceased

‘O Allaah, forgive - here the name of the deceased is mentioned - and raise his rank among the rightly guided, and be a successor to whom he has left behind, and forgive us and him O Lord of the worlds. Make spacious his grave and illuminate it for him.’


[051] Supplication for the deceased at the funeral prayer

‘O Allaah, forgive and have mercy upon him, excuse him and pardon him, and make honourable his reception. Expand his entry, and cleanse him with water, snow and hail, and purify him of sin as a white robe is purified of filth. Exchange his home for a better home, and his family for a better family, and his spouse for a better spouse. Admit him into the Garden, protect him from the punishment of the grave and the torment of the Fire.’

‘O Allaah, forgive our living and our dead, those present and those absent, our young and our old, our males and our females. O Allaah, whom amongst us You keep alive, then let such a life be upon Islaam, and whom amongst us You take unto Yourself, then let such a death be upon faith. O Allaah, do not deprive us of his reward and do not let us stray after him.’

‘O Allaah, so-and-so is under Your care and protection so protect him from the trial of the grave and torment of the Fire. Indeed You are faithful and truthful. Forgive and have mercy upon him, surely You are The Oft-Forgiving, The Most-Merciful.’

‘O Allaah, Your servant and the son of Your maidservant is in need of Your mercy and You are without need of his punishment. If he was righteous then increase his reward and if he was wicked then look over his sins.’


[052] Supplication for the advancement of reward during the funeral prayer

One can also say:

‘O Allaah, make him a preceding reward and a stored treasure for his parents, and an answered intercessor. O Allaah, through him, make heavy their scales and magnify their reward. Unite him with the righteous believers, place him under the care of Ibraaheem, and protect him by Your mercy from the torment of Hell.’

al-Hasan used to recite the opening Soorah of the Qur.aan [i.e., al-Faatihah] over the child and then supplicate:

‘O Allaah, make him a preceding reward, a prepayment and a recompense for us.’


[053] Condolence

‘Verily to Allaah, belongs what He took and to Him belongs what He gave, and everything with Him has an appointed time…and then he (sal-Allaahu 'alayhe wa sallam) ordered for her to be patient and hope for Allaah’s reward .’

...and one can also say:

‘May Allaah magnify your reward, make better your solace and forgive your deceased.’


[054] Placing the deceased in the grave

‘In the name of Allaah and upon the Sunnah of the Messenger of Allaah.’


[055] After burying the deceased

‘After The Prophet (sal-Allaahu 'alayhe wa sallam) would bury the deceased he would stand by the grave and say: ‘Seek forgiveness for your brother and pray that he remains firm, for he is now being questioned’.’


[056] Visiting the graves

‘Peace be upon you all, O inhabitants of the graves, amongst the believers and the Muslims. Verily we will, Allaah willing, be united with you, may Allaah have mercy upon those already called and those still delayed among us all. We ask Allaah for well-being for us and you.’


[057] During a wind storm

‘O Allaah, I ask You for it’s goodness and I take refuge with You from it’s evil.’

‘O Allaah, I ask You for it’s goodness, the good within it, and the good it was sent with, and I take refuge with You from it’s evil, the evil within it, and from the evil it was sent with.’


[058] Upon hearing thunder

When 'Adbullaah Ibn az-Zubayr (radhi-yAllaahu 'anhu) used to hear thunder he would stop talking and say:

‘How perfect He is, [The One] Whom the thunder declares His perfection with His praise, as do the angels out of fear of Him.’


[059] Supplication for rain

‘O Allaah, send upon us helpful, wholesome and healthy rain, beneficial not harmful rain, now, not later.’

‘O Allaah, relieve us, O Allaah, relieve us, O Allaah, relieve us.’

‘O Allaah, provide water for Your servants and Your cattle, spread out Your mercy and resurrect Your dead land.’


[060] When it rains

‘O Allaah, may it be a beneficial rain cloud.’


[061] After rainfall

‘We have been given rain by the grace and mercy of Allaah.’


[062] Asking for clear skies

‘O Allaah, let the rain fall around us and not upon us, O Allaah, [let it fall] on the pastures, hills, valleys and the roots of trees.’


[063] Upon sighting the crescent moon

‘Allaah is the greatest. O Allaah, let the crescent loom above us in safety, faith, peace, and Islaam, and in agreement with all that You love and pleases You, O our Lord. Our Lord and your Lord is Allaah.’


[064] Upon breaking fast

‘The thirst has gone and the veins are moistened, and reward is confirmed, if Allaah wills.’

'Adbullaah Ibn 'Amr Ibn al-'Aas (radhi-yAllaahu 'anhu) related that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) said: ‘Indeed the fasting person has at the time of breaking fast, a supplication which is not rejected’. Ibn Abee Mulaykah (rahima-hullaah) said: ‘I Heard 'Adbullaah Ibn 'Umar (radhi-yAllaahu 'anhumaa) say when he broke his fast:

‘O Allaah, I ask You by Your mercy which envelopes all things, that You forgive me.’


[065] Supplication before eating

‘When you are about to eat, you should say:

...and if you forget to say it before starting, then you should say [when you remember]:

‘In the name of Allaah in its beginning and end.’

‘Whomever Allaah feeds, should say:

‘O Allaah, bless it for us and feed us better than it.’

...and whomever Allaah gives milk to drink, should say:

‘O Allaah, bless it for us and give us more of it.’


[066] Upon completing the meal

‘All praise is for Allaah who fed me this and provided it for me without any might nor power from myself.’

‘Allaah be praised with an abundant beautiful blessed praise, a never-ending praise, a praise which we will never bid farewell to and an indispensable praise, He is our Lord .’


[067] Supplication of the guest for the host

‘O Allaah, bless for them, that which You have provided them, forgive them and have mercy upon them.’


[068] Supplication said to one offering a drink or to one who intended to do that

‘O Allaah, feed him who fed me, and provide with drink him who provided me with drink.’


[069] When breaking fast in someone’s home

‘May the fasting break their fast in your home, and may the dutiful and pious eat your food, and may the angels send prayers upon you.’


[070] Supplication said by one fasting when presented with food and does not break his fast

‘If you are invited [to a meal] then answer. If you happen to be fasting, then supplicate [for those present] and if you are not fasting, then eat.’


[071] Supplication said upon seeing the early or premature fruit

‘O Allaah, bless our fruit for us, bless our town for us, bless our Saa' for us and bless our Mudd for us.’


[072] Upon sneezing

‘When one of you sneezes he should say:

‘All praise is for Allaah’

...and his brother or companion should say to him:

‘May Allaah have mercy upon you.’

...and he [i.e. the one who sneezed] replies back to him:

‘May Allaah guide you and rectify your condition.’


[073] Supplication said to the newlywed

‘May Allaah bless for you [your spouse] and bless you, and may He unite both of you in goodness.’


[074] The groom’s supplication on the wedding night or when buying an animal

When you marry a woman or buy a maidservant, you should say:

‘O Allaah, I ask You for the goodness within her and the goodness that you have made her inclined towards, and I take refuge with You from the evil within her and the evil that you have made her inclined towards.’

...and if you buy a camel, then you should take hold of it’s hump and say likewise.’


[075] Before sexual intercourse

‘In the name of Allaah. O Allaah, keep the devil away from us and keep the devil away from what you have blessed us with.’


[076] When angry

‘I take refuge with Allaah from the accursed devil.’


[077] Supplication said upon seeing someone in trial or tribulation

‘All praise is for Allaah Who saved me from that which He tested you with and Who most certainly favoured me over much of His creation.’


[078] Remembrance said at a sitting or gathering etc.

Ibn 'Umar (radhi-yAllaahu 'anhumaa) said: It would be counted that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) would say one hundred times at any one sitting before getting up:

‘O my Lord, forgive me and turn towards me [to accept my repentance]. Verily You are The Oft-Returning, The Oft-Forgiving.’


[079] Supplication for the expiation of sins said at the conclusion of a sitting or gathering etc.

‘How perfect You are O Allaah, and I praise You. I bear witness that None has the right to be worshipped except You. I seek Your forgiveness and turn to You in repentance.’


[080] Returning a supplication of forgiveness

'Adbullaah Ibn Sarjis (radhi-yAllaahu 'anhu) said: ‘ I went to see The Prophet (sal-Allaahu 'alayhe wa sallam) and ate from his food and then said to him:

‘May Allaah forgive you, O Messenger of Allaah.’

...He (sal-Allaahu 'alayhe wa sallam) replied:

‘and you.’


[081] Supplication said to one who does you a favour

‘If someone does you a favour and you say:

‘May Allaah reward you with goodness.’

...then you have indeed excelled in praising him.’


[082] Protection from the Dajjaal

‘Whoever memorises the first ten Aayaat of Soorah al-Kahf will be protected from Dajjaal.’

One should also seek refuge with Allaah from the tribulations of the Dajjaal after the last tashahhud of every prayer.


[083] Supplication said to one who pronounces his love for you, for Allaah’s sake

‘May He, for whom you have loved me, love you.’


[084] Supplication said to one who has offered you some of his wealth

‘May Allaah bless for you, your family and wealth.’


[085] Supplication said to the debtor when his debt is settled

‘May Allaah bless for you, your family and wealth. Surely commendation and payment are the reward for a loan.’


[086] Supplication for fear of shirk

‘O Allaah, I take refuge in You lest I should commit shirk with You knowingly and I seek Your forgiveness for what I do unknowingly.’


[087] Returning the supplication of one who says ‘May Allaah bless you’

'Aa.ishah (radhi-yAllaahu 'anhaa) reported that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) was given a sheep and he ordered for it’s distribution. When the servant would come back [from distributing it], 'Aa.ishah would ask: ‘What did they say?’, he replied: ‘They would supplicate:

‘May Allaah bless you all.’

...'Aa.ishah would then say:

‘and may Allaah bless them.’

...we return their supplication in a similar way and our reward remains with us.


[088] Forbiddance of ascribing things to omens

‘O Allaah, there is no omen but there is reliance on You, there is no good except Your good and none has the right to be worshipped except You.’


[089] When mounting an animal or any means of transport

‘In the name of Allaah and all praise is for Allaah. How perfect He is, the One Who has placed this [transport] at our service and we ourselves would not have been capable of that, and to our Lord is our final destiny. All praise is for Allaah, All praise is for Allaah, All praise is for Allaah. Allaah is the greatest, Allaah is the greatest, Allaah is the greatest. How perfect You are, O Allaah, verily I have wronged my soul, so forgive me, for surely none can forgive sins except You.’


[090] Supplication for travel

‘Allaah is the greatest, Allaah is the greatest, Allaah is the greatest, How perfect He is, The One Who has placed this [transport] at our service, and we ourselves would not have been capable of that, and to our Lord is our final destiny. O Allaah, we ask You for birr and taqwaa in this journey of ours, and we ask You for deeds which please You. O Allaah, facilitate our journey and let us cover it’s distance quickly. O Allaah, You are The Companion on the journey and The Successor over the family, O Allaah, I take refuge with You from the difficulties of travel, from having a change of hearts and being in a bad predicament, and I take refuge in You from an ill fated outcome with wealth and family.’

...upon returning the same supplication is recited with the following addition:

‘We return, repent, worship and praise our Lord.’


[091] Supplication upon entering a town or village etc.

‘O Allaah, Lord of the seven heavens and all that they envelop, Lord of the seven earths and all that they carry, Lord of the devils and all whom they misguide, Lord of the winds and all whom they whisk away. I ask You for the goodness of this village, the goodness of its inhabitants and for all the goodness found within it and I take refuge with You from the evil of this village, the evil of its inhabitants and from all the evil found within it.’


[092] When entering the market

‘None has the right to be worshipped except Allaah, alone, without any partner, to Him belongs all sovereignty and praise. He gives life and causes death, and He is living and does not die. In His hand is all good and He is over all things, omnipotent.’


[093] Supplication for when the mounted animal [or mean of transport] stumbles

‘In the name of Allaah.’


[094] Supplication of the traveller for the resident

‘I place you in the trust of Allaah, whose trust is never misplaced.’


[095] Supplication of the resident for the traveller

‘I place your religion, your faithfulness and the ends of your deeds in the trust of Allaah.’

‘May Allaah endow you with taqwaa , forgive your sins and facilitate all good for you, wherever you be.’


[096] Remembrance while ascending or descending

Jaabir (radhi-yAllaahu 'anhu) said: While ascending, we would say:

‘Allaah is the greatest.’

...and when descending, we would say:

‘How perfect Allaah is.’


[097] Prayer of the traveller as dawn approaches

‘May a witness, be witness to our praise of Allaah for His favours and bounties upon us. Our Lord, protect us, show favour on us and deliver us from every evil. I take refuge in Allaah from the fire.’


[098] Stopping or lodging somewhere

‘I take refuge in Allaah’s perfect words from the evil that He has created.’


[099] While returning from travel

Ibn 'Umar (radhi-yAllaahu 'anhaa) reported that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) on return from a battle or from performing the pilgrimage would say at every high point:

‘Allaah is the greatest, Allaah is the greatest, Allaah is the greatest.’

...and then he would say:

‘None has the right to be worshipped except Allaah, alone, without any partner. To Him belong all sovereignty and praise, and He is over all things omnipotent. We return, repent, worship and praise our Lord. Allaah fulfilled His promise, aided His Servant, and single-handedly defeated the allies.’


[100] What to say upon receiving pleasing or displeasing news

When He (sal-Allaahu 'alayhe wa sallam) used to receive pleasant news, He (sal-Allaahu 'alayhe wa sallam) would say:

‘All Praise is for Allaah by whose favour good works are accomplished.’

...and upon receiving displeasing news, He (sal-Allaahu 'alayhe wa sallam) would say:

‘All Praise is for Allaah in all circumstances.’


[101] Excellence of sending prayers upon the Prophet

The Prophet (sal-Allaahu 'alayhe wa sallam) said: ‘Whoever sends a prayer upon me, Allaah sends ten upon him.’

He (sal-Allaahu 'alayhe wa sallam) also said: ‘Do not take my grave as a place of habitual ceremony. Send prayers upon me, for verily your prayers reach me wherever you are.’

He (sal-Allaahu 'alayhe wa sallam) also said: ‘The miser is one whom when I am mentioned to him, fails to send prayers upon me.’

He (sal-Allaahu 'alayhe wa sallam) said: “Allaah has Angels who roam the earth and convey salaam to me from my ummah.”

He (sal-Allaahu 'alayhe wa sallam) also said: “Whenever someone sends salaam upon me, Allaah returns my soul to me so that I may return salaam to that person.”


[102] Excellence of spreading the Islaamic greeting

The Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) said: ‘You shall not enter paradise until you believe, and you shall not believe until you love one another. Shall I not inform you of something, if you were to act upon it, you will indeed achieve mutual love for one another? Spread salaam amongst yourselves.’

'Ammaar (radhi-yAllaahu 'anhu) said: ‘Three characteristics, whoever combines them, has completed his faith: to be sincerely just, to spread greetings to all people and to spend [charitably] out of the little you have.’

'Abdullaah Ibn 'Amr (radhi-yAllaahu 'anhu) reported that a man asked The Prophet (sal-Allaahu 'alayhe wa sallam): ‘Which Islaam is the best?’. He (sal-Allaahu 'alayhe wa sallam) replied: Feed [the poor], and greet those whom you know as well as those whom you do not.’


[103] Upon hearing a rooster crow or the braying of an ass

‘If you hear the crow of a rooster, ask Allaah for his bounty for it has seen an angel and if you hear the braying of an ass, seek refuge in Allaah for it has seen a devil.’


[104] Upon hearing the barking of dogs at night

‘If you hear the barking of dogs or the braying of asses at night, seek refuge in Allaah for they see what you do not.’


[105] Supplication said for one you have insulted

‘O Allaah, to any believer whom I have insulted, let that be cause to draw him near to You on the Day of Resurrection.’


[106] The etiquette of praising a fellow Muslim

He (sal-Allaahu 'alayhe wa sallam) said: ‘If anyone of you is impelled to praise his brother, then he should say: ‘I deem so-and-so to be...and Allaah is his reckoner...and I don’t praise anyone, putting it [i.e., my praising] forward, in front of Allaah’s commendation, however I assume him to be such and such’ - if he knows that of him.’


[107] Supplication said between the Yemeni corner and the black stone [at the Ka'bah]

The Prophet (sal-Allaahu 'alayhe wa sallam) used to say between the Yemeni corner and the black stone:

[Soorah al-Baqarah, Aayah 201]

‘O our Lord, grant us the best in this life and the best in the next life, and protect us from the punishment of the Fire.’


[108] When standing at Mount as-Safaa and Mount al-Marwah

Jaabir (radhi-yAllaahu 'anhu) said when describing the Prophet’s (sal-Allaahu 'alayhe wa sallam) pilgrimage: ‘...and when he approached mount as-Safaa he recited:

[Soorah al-Baqarah, Aayah 158]

‘Indeed as-Safaa and al-Marwah are from the places of worship of Allaah...’

‘I begin with what Allaah began with.’

...so he started with as-Safaa and climbed it until he could see the Ka'bah, he then faced it and said:

‘Allaah is the greatest, Allaah is the greatest, Allaah is the greatest.’

...and then he would say the following three times making a supplication after each time:

‘None has the right to be worshipped except Allaah, alone, without any partner. To Him belong all sovereignty and praise and He is over all things omnipotent. None has the right to be worshipped except Allaah alone. He fulfilled His promise, aided His Servant and single-handedly defeated the allies.’

...He (sal-Allaahu 'alayhe wa sallam) would repeat this action at Marwah.


[109] The Day of 'Arafah

‘The best of supplications is the supplication on the day of 'Arafah and the best which I and the Prophets before me have said is:

‘None has the right to be worshipped except Allaah, alone, without any partner. To Him belong all praise and sovereignty and He is over all things omnipotent.’


[110] At the Sacred Site [al-Mash'ar al-Haraam]

Jaabir (radhi-yAllaahu 'anhu) said: ‘He (sal-Allaahu 'alayhe wa sallam) rode al-Qaswaa until he reached al-Mash'ar al-Haraam, he then faced the qiblah, supplicated to Allaah, and extolled His greatness and oneness. He stood until the sun shone but left before it rose.’


[111] When throwing each pebble at the Jamaraat

Every time The Prophet (sal-Allaahu 'alayhe wa sallam) threw a pebble at any of the three jamaraat, he would say:

‘Allaah is the greatest.’

...on completion of the first jamarah, he advanced a little, stood facing the qiblah, raised his hands and supplicated. He also did this after the second jamarah but not the third.’


[112] At the black stone

‘The Prophet (sal-Allaahu 'alayhe wa sallam) circled the Ka'bah on a camel, every time he reached the black stone he would point to it with his staff and say:

‘Allaah is the greatest.’


[113] Supplication made against an enemy

‘O Allaah, Revealer of the Book, Swift at reckoning, defeat the confederates. O Allaah, defeat them and convulse them.’


[114] What to say when in fear of a people

‘O Allaah, protect me from them with what You choose.’


[115] What to say at times of amazement and delight

‘How perfect Allaah is!’

‘Allaah is the greatest!’


[116] What to do upon receiving pleasant news

The Prophet (sal-Allaahu 'alayhe wa sallam) would prostrate in gratitude to Allaah (Subhaanahu wa Ta'aala) upon receiving news which pleased him or which caused pleasure.


[117] What to say and do when feeling some pain in the body

‘Place your hand at the site of the pain and say:

‘In the name of Allaah.’ [three times]

...then supplicate seven times:

‘I take refuge in Allaah and within His omnipotence from the evil that I feel and am wary of.’


[118] What to say when in fear of afflicting something or someone with one’s eye

‘If you see something from your brother, yourself or wealth which you find impressing, then invoke blessings for it, for the evil eye is indeed true’.


[119] Etiquette of retiring for the night

‘When night falls [i.e., at al-Maghrib], restrain your children [from going out] because at such time the devils spread about. After a period of time has passed, let them be. Shut your doors and mention Allaah’s name, for verily the devil does not open a shut door, tie up your water-skins and mention Allaah’s name, cover your vessels with anything and mention Allaah’s name and put out your lamps.’

O Allaah, send peace and blessings upon our Prophet Muhammad, his companions, and his family and all those who follow them in righteousness till the Day of Reckoning.


[120] The Talbiyah for Hajj or 'Umrah

‘Here I am O Allaah, [in response to Your call], here I am. Here I am, You have no partner, here I am. Verily all praise, grace and sovereignty belong to You. You have no partner.’


[121] What to say when startled

‘None has the right to be worshipped except Allaah.’


[122] What is said to a kaafir when he sneezes

‘May Allaah guide you and rectify your condition.’


[123] Returning a greeting to a kaafir

‘When the people of the Book greet you, reply by saying:

‘And upon you.’


[124] When insulted while fasting

‘I am fasting, I am fasting.’


[125] When slaughtering or offering a sacrifice

‘In the name of Allaah, and Allaah is the greatest. O Allaah, it is from You and belongs to You, O Allaah, accept this from me.’


[126] To ward off the deception of the obstinate Shaytaans

‘I take refuge within Allaah’s perfect words which no righteous or unrighteous person can transgress, from all the evil that He has created, made and originated. [I take refuge] from the evil that descends from the sky and the evil that rises up to it. [I take refuge] from the evil that is spread on earth and the evil that springs from her, and I take refuge from the evil of the tribulations of night and day, and the evil of one who visits at night except the one who brings good, O Merciful One.’


[127] Seeking forgiveness and repentance

‘The Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) said: ‘By Allaah, I seek forgiveness and repent to Allaah, more than seventy times a day.’

He (sal-Allaahu 'alayhe wa sallam) also said: ‘O People, Repent to Allaah! Verily I repent to Him a hundred times a day.’

He (sal-Allaahu 'alayhe wa sallam) also said: ‘Whoever says:

‘I seek Allaah’s forgiveness, besides whom, none has the right to be worshipped except He, The Ever Living, The Self-Subsisting and Supporter of all, and I turn to Him in repentance.’

...Allaah would forgive him even if he was one who fled during the advance of an army.’

He (sal-Allaahu 'alayhe wa sallam) said: ‘The nearest the Lord comes to His servant is in the middle of the night, so if you are able to be of those who remember Allaah at that time, then be so.’

He (sal-Allaahu 'alayhe wa sallam) also said: ‘The nearest a servant is to his Lord is when he is prostrate, so supplicate much therein.’

He (sal-Allaahu 'alayhe wa sallam) also said: ‘Verily my heart becomes preoccupied , and verily I seek Allaah’s forgiveness a hundred times a day.’


[128] Excellence of remembrance and glorification of Allaah

‘Whoever says:

‘How perfect Allaah is and I praise Him.’

...a hundred times during the day, his sins are wiped away, even if they are like the foam of the sea.’

Abu Ayyoob al-Ansaaree (radhi-yAllaahu 'anhu) related that The Prophet (sal-Allaahu 'alayhe wa sallam) said: ‘Whoever says:

‘None has the right to be worshipped except Allaah, alone, without any partner. To Him belong all sovereignty and praise and He is over all things omnipotent.’

...ten times, is like one who has freed four souls from among the children of Ismaa'eel.’

Abu Hurayrah (radhi-yAllaahu 'anhu) reported that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) said: ‘[There are] Two words, [which are] light on the tongue, heavy on the Scale and beloved to The Most Gracious:

‘How perfect Allaah is and I praise Him. How perfect Allaah is, The Supreme.’

Abu Hurayrah (radhi-yAllaahu 'anhu) reported that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) said: ‘Saying:

‘How perfect Allaah is, and all praise is for Allaah. None has the right to be worshipped except Allaah, and Allaah is the greatest.’

...is more beloved to me than everything the sun has risen over.’

Sa'd (radhi-yAllaahu 'anhu) said: ‘We were sitting with the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) , and he said: ‘Are any of you unable to gain a thousand good deeds each day?’ Somebody then asked him (sal-Allaahu 'alayhe wa sallam): How does one achieve a thousand good deeds? He replied: ‘He should say:

‘How perfect Allaah is.’

...one hundred times, for a thousand good deeds are recorded for him or a thousand bad deeds are wiped away.’

Jaabir (radhi-yAllaahu 'anhu) related that The Prophet (sal-Allaahu 'alayhe wa sallam) said: ‘Whoever says:

‘How perfect Allaah is, The Supreme, and I praise Him.’

...a palm tree is planted for him in Paradise.’

'Adbullaah Ibn Qays (radhi-yAllaahu 'anhu) related that The Prophet (sal-Allaahu 'alayhe wa sallam) said to him: ‘ O 'Adbullaah Ibn Qays, shall I not inform you of a treasure from the treasures of paradise?’ He (sal-Allaahu 'alayhe wa sallam) then said: ‘Say:

‘There is no might nor power except with Allaah.’

‘The most beloved words to Allaah are four:

‘How perfect Allaah is, all praise is for Allaah. None has the right to be worshipped except Allaah and Allaah is the greatest.’

...it does not matter which of them you start with.’

Sa'd Ibn Abee Waqqaas (radhi-yAllaahu 'anhu) narrated that a man came to the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) and said to him: ‘Teach me something which I should say?’ He (sal-Allaahu 'alayhe wa sallam) said: ‘Say:

‘None has the right to be worshipped except Allaah, alone without any partner. Allaah is most great and much praise is for Allaah. How perfect Allaah is, Lord of the worlds. There is no might nor power except with Allaah, The Exalted in might, The Wise.’

...the man then said: ‘These are for my Lord, and what is for me?’ He (sal-Allaahu 'alayhe wa sallam) replied: ‘Say:

‘O Allaah, forgive me, have mercy upon me, guide me and grant me sustenance.’

Taariq al-Ashja'ee (radhi-yAllaahu 'anhu) said: ‘When someone would embrace Islaam, The Prophet (sal-Allaahu 'alayhe wa sallam) would teach him how to perform prayer and then order him to supplicate with the following words:

‘O Allaah, forgive me, have mercy upon me, guide me, give me health and grant me sustenance.’

Jaabir Ibn 'Adbullaah (radhi-yAllaahu 'anhu) related that the Messenger of Allaah (sal-Allaahu 'alayhe wa sallam) said: ‘Verily, the best supplication is:

‘All praise is for Allaah.’

...and indeed, the best form of remembrance is:

‘None has the right to be worshipped except Allaah.’

‘The everlasting righteous deeds:

‘How perfect Allaah is, and all praise is for Allaah. None has the right to be worshipped except Allaah, and Allaah is the greatest. There is no might nor power except with Allaah.’


[129] How the Prophet made tasbeeh

'Adbullaah Ibn 'Amr (radhi-yAllaahu 'anhu) said: ‘I saw The Prophet (sal-Allaahu 'alayhe wa sallam) make tasbeeh with his right hand.’